Talent Acquisition Suite - Investigating CRM data delay Issue

Incident Report for Symphony Talent

Resolved

This issue is now resolved
Posted Jun 26, 2026 - 14:17 EDT

Monitoring

A fix has been implemented and normal processing speeds have been restored in the CRM for Candidate and Folder data. Our teams will continue to monitor.
Posted Jun 26, 2026 - 12:48 EDT

Investigating

We are currently investigating delays affecting some data in the CRM

Impact
Clients may experience some slowness in the CRM with Candidate and Folder data.
We are actively working to resolve this and will provide a further update shortly.
Posted Jun 26, 2026 - 08:06 EDT
This incident affected: SFX - CRM.