Skillcheck Services Outage
Incident Report for Symphony Talent
Resolved
The incident has been resolved and steps are being taken to prevent this condition in the future.
Posted Jul 28, 2021 - 11:49 EDT
Update
We are continuing to investigate this issue.
Posted Jul 28, 2021 - 11:48 EDT
Investigating
We are aware of an issue with our Skillcheck product and are currently investigating.
Posted Jul 28, 2021 - 11:27 EDT
This incident affected: SkillCheck - Assessment Testing.