CWS - Jobs Issue Being Investigated

Incident Report for Symphony Talent

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 17:27 EST

Monitoring

Full functionality has now returned to all Career Websites and jobs are displaying as expected. Our team is now monitoring to ensure stability.
Posted Mar 04, 2025 - 16:36 EST

Investigating

We are currently investigating an issue related our Career Websites. Sites with Google Talent Cloud in place may see a disruption in the flow loading.
Posted Mar 04, 2025 - 16:25 EST
This incident affected: SFX - Career Websites (CWS).